Search Posts:

Permanently set MULTINET_SMTP_REPLY_TO

View Entire Thread

Return to Threads

SHARE
  by Bill Degnan - 10/03/2019 07:49
Adding to the earlier message in this thread you can't set the reply-to value in the multinet menu-drrven config tool

$ MULTINET CONFIGURE /MENU

...or command line. Further, you can't insert a line that sets the reply to value in systartup_v5.com because MULTINET_SMTP_REPLY_TO is set after login.

I edited the SYSTEM user's login.com (each user has their own) to include the DEFINE statement to set MULTINET_SMTP_REPLY_TO for SYSTEM, and proceeded to do this in a regular user's account.

...worked.

This means that if you want to protect the gateway from being hijacked, EVERY USER needs to have an alias created on the gateway mail server I am using (buzz1.com) that forwards mail to its corresponding microvax 3100 user. The buzz1.com mail user will be DEFINE'd in at the user level's login.com

see also:
Prevent VMS MULTINET SMTP Relay Hijacks

and

Adding VMS Users

and

Setting Disk Quota

next I could set up a pattern for a lexical function such as for example
F$GETJPI(0, "USERNAME") to come up with a single logical name definition that
will work correctly for any user on the system without modification *assuming the gateway pair email alias uses same format*. i.e. hjohnson@vmsmailserverdomain.com --> hjohnson@gatewaymailserverdomain.com


Reply

Resources:


Buy a Commodore Computer Poster

Popular Topics and FAQs


Past Issues:


Intel MDS 720 cleaned

This image was selected at random from the archive. Click image for more photos and files from this set.