Search Posts:

Booting the System Using RL02 drive


Return to Threads

  Booting the System Using RL02 drive by Bill Degnan - 07/20/2015 09:27
M9312 Bootstrap Terminator CONSOLE Test
I set the jumpers on the M9312 card to use the CONSOLE program. The CONSOLE is a monitor program that allows a person to load a RAM address, change memory, load and run programs rather than have to rely on the front panel. This image shows the echo character program from the manual. The last line reads: @STHIS IS A TEST.... @ is the prompt, S is the start command. I then typed THIS IS A TEST, without a LF CR. Click on image for larger view.

I have one RL01/RL02 ROMS that I can use with the M9213. I read the ROM to compare with the bootstrap listed below to verify I have the correct ones.

The RL02 bootstrap is here

Below I have a listing of what is in RAM when I check using the console. 173204 is the address to start the bootstrap. Except for the first line, it's a match. 173000

Starting point (*) for ROM slot 1, NO diagnostics is 173004

The M9312 is set to run the bootstrap in ROM 1 with the command DL

173200 042114
173202 000176
173204 000261
173206 012700
173210 000000
173212 012701
173214 174400
173216 010704
173220 103064
173222 000402
173224 173000
173226 000340
173230 010003
173232 000303
173234 010311
173236 012761
173240 000013
173242 000004
173244 052703
173246 000004
173250 010311
173252 105711
173254 100376
173256 105003
173260 052703
173262 000010
173264 010311
173266 105711
173270 100376
173272 016102
173274 000006
173276 042702
173300 000077
173302 005202
173304 010261
173306 000004
173310 105003
173312 052703
173314 000006
173316 010311
173320 105711
173322 100376
173324 005061
173326 000004
173330 012761
173332 177000
173334 000006
173336 105003
173340 052703
173342 000014
173344 010311
173346 105711
173350 100376
173352 005711
173354 100003
173356 000005
173360 000164
173362 000002
173364 042711
173366 000377
173370 005007
173372 000137
173374 165564
173376 171540

  M7762 Drive controller by Bill Degnan - 07/25/2015 08:15
I tested two drives and verified cables. There is no fault light on the drive. It appears that the drive controller I am using is bad OR maybe there is a grant continuity card issue, not sure yet.

  Tracing Bootstrap Fault by Bill Degnan - 07/29/2015 18:47
The boot process appears to be looping over and over again

system is looping between instructions 173022 -->173156 (error reset the world), 173160 (retry)..back to 173022

I have the card on a hex riser so I can probe the signals live. I also started cleaning my backup M7762 card and tried it out, but it only goes from 173052 and 173054 (test for ready/wait/test for ready/wait)

When I first power on the values in the control status register (774400) are good. 1-6 and 8-13 are cleared, bit 7 is set.
After I attempt to boot (DL at the @ prompt), you can see the light pattern repeat over and over, looping through 173022 -->173160.
I HALT the system and recheck the control status register. This time
15 - error (composite error (ERR))
10 - EO (operation incomplete (OPI))
7 - stays lit
function code F2 = 1, F1 =1, F0 =0. this code indicates "HFT" (Header Not Found)

  PDP11GUI by Bill Degnan - 07/30/2015 11:06
I will go the "... PDP11GUI can be used to transfer diagnostics programs directly into the PDP-11 ..." route given I don't have a slot available for a 2nd M7856 (and thus can't emulate a TU58). This way I can load programs into the system such as diagnostics in order to rule out any CPU/RAM issues being the cause of the bootstrap loop issue.

  XXDP Tape images by Bill Degnan - 08/03/2015 11:36

Download the .BIC images and load into memory using PDPGUI, as "Absolute Papertape Format" then run following PDF explanation.

  UNIBUS configuration by Bill Degnan - 08/31/2015 10:59
UNIBUS card positioning. Click for larger image.

Dave M stopped by and made adjustments to the UNIBUS Non Processor Grant (NPG) lines on the UNIBUS. I had been asking around how exactly to make sure the NPG was happening when it needed to happen and disconnected when it should be missing. We did the following, for space reasons.

1) Removed NPG from wirewrap of last 5-slot backplane row per requirements for installation of M7762 RL11. I understand now better how the NPG works.

2) found pin on backplane that already did have this jumper removed and put a NPG card in this slot (3-4). This is a requirement for proper operation of the UNIBUS. This is the slot also used by the 9312 (1-2).

Card placement Front
Card placement Corner. Note, you can't see all of the way to the corner in this photo. If you could see where the M7762 connects to the backplane you'd see I've run out of slots. The "expansion" has no terminator a the end. Does not seem to be a problem, but not 100% sure. It is a 5-slot backplane.

3) Ran bootstrap. Now, Some code is written into the 000 000 page from the disk, but RL11 fails to boot.

- Check drive cable
- measure voltage across a M7762 cap while simultaneously boosting voltage
at the h744 regulator level. -->5.1v
- I have two or three h744's on this system so I have to id which one is
- step through bootstrap, compare with what I had before, there is a diag
address I can check too
- Verify all drive, pack, and cable combinations return the same result.
- Is the lack of a terminator preventing bootstrap (unlikely?)
- Could it be that there is a conflict between the M9312 and the drive controler ROMs? Try booting without the CONSOLE ROM in place.

  Further Testing by Bill Degnan - 05/11/2016 11:03
I tested and verified the operation of the 64K (Not 128K) RAM card I have installed.

I tested four M7762 RL/02 controllers. One is outright bad, the other three all seem to have no issue initiating the boot (the READY light blips out for a milisecond whe DL0 is run) but they all bomb after writing the 000 000 page data to initiate the disk read.

The current configuration has only the main CPU backplane and a 1/2 backplane. There is not enough room for the M930 bus terminator, I have to remove it in order to give up a slot for the M7762 drive controller.

Let's try putting the M930 back into the last slot. I will also remove the M9312 and G7273 and replace with the RL02 controller. I will toggle-in the bootstrap manually and attempt to boot.

  M9312 OK by Bill Degnan - 06/16/2016 14:54
After methodically working through everything else, I was able to use the M9312 again with a 16K core stack this time. It's also set to be a terminator and sits in A/B of the last slot in the UNIBUS backplane. I can run the CONSOLE again. I now have a few replacement ROMs to try with the RL02 controller.

I still can't boot up, or even appear to try to boot up. The system appears stuck blinking through an endless loop.

Could it be the cable? Terminator? What is it man?!!!!

  Switch to DD11B backplane? by Bill Degnan - 06/27/2016 09:28
I was told that could abandon the DD11C and switch instead to a DD11B backplane

"...*RL11 *controller instead, which is a hex SPC compatible module. This means the A/B sections only have +5/GND power connections, and sections C/D/E/F are the standard UNIBUS SPC pinout. So the RL11 controller could go in any of the above backplanes in SPC slots 2 thru N-1 (ie, not first or last SPC slots, as those have UNIBUS IN/OUT in sections A/B). So your RL11 could go in a DD11-B slots 2 or 3, and a DL11-A/B/C/D/E/W could go in any of DD11-B slots 1 thru 4.

But according to the RL01/RL02 manual one must install in a UNIBUS slot only after the jumper between CAl and CBl (NPR Grant) on the backplane has been removed, if the jumper exists. This jumper is present on all slots of the DD11B.

On my modified DD11C, slots 2 and 4 have this jumper removed, as far as I can tell. To test I put in a hex extender card, then found the pins where the NPR Grant could would be located. I used my volt meter to do a continuity test between the pins the NPR Grant card closes. If the connection beeps, I take this to mean that the backplane slot *is* jumpered and thus is not a candidate slot for the M7762 controller.

  RL11 Diagnostics by Bill Degnan - 07/09/2016 09:30
This thread continues here

  Let's try more RAM by Bill Degnan - 07/21/2016 01:47
The RT 11 diskpack Ray Fantini gave me is version 5.? and I was told I might need a minimim of 28K W to run it.

So, I replaced my 16K core stack cards with a single 64K MOS RAM board to see if that makes a difference. This is the M7891 I was using before. The board is an MS11-L. Its installed in slot 3 of my DD11-CF backplane. Slot 3 is a MUD slot without the NPG jumper removed. The manual says it will work in any MUD slot. It seems to work OK. I ran a memory diagnostic and loaded BASIC.

On the same backplane slot 2 is a MUD slot with the NPG jumper removed. I have had the RL11 controller installed there. The RL11 manual says the M7762 should be installed in a MUD slot with the NPG removed.

I believe I have concluded correctly where to put the MOS and RL11 controllers and that they can be together. I asked around for dissenting opinions...

If replacing the 16K core with the 64K MOS RAM will load RT11, I would conclude that one needs more than 16K installed in the system for version 5 all else being the same.

  Need EIS (M7238) KE11-E? by Bill Degnan - 07/21/2016 11:24
So I was thinking given the standard SIMH config for the PDP 11/40 includes installation of an emulated Extended Instruction Set (KE11-E M7238) module, perhaps RT-11 needs this.

It turns out the two KE11-E's I have on hand are apparently bad. I confirmed this by first installing a test M7233 IR DECODE card that had been used in a system with a KE11-E. You can tell because W1 is cut. I temporarily jumpered the IR DECODE (M7233) card and installed in the 11/40 without a KE11-E in order to confirm it works. Next I removed the W1 jumper from the M7233 and I installed the KE11-E M7838 module. I attached the three cables between the M7238 and M7832.

First card - bombs the CPU
2nd card - also bombs the CPU.

Conclusion - I know now I have at least one extra working IR DECODE card (M7233) but I have no working KE11-E (M7238). Thus I have no way to include the EIS in the CPU configuration.

I learned from the vcfed forum that the EIN is not necessary. The 11/20 can boot RT11 with 32K and no EIS (and presumably the 11/05).

While I was testing things, I verified my MS11-L (M7791) MOS RAM (64K) passed enough tests to satisfy me that it was ok. I also loaded and ran BASIC. One thing to check into...I got a red light when I answered the MEMORY? question with a carriage return rather than entering in an amount. A quick system reset and load/run at 000 opened BASIC and it ran fine. It may be for the MOS RAM parity circuit you have to specify the RAM memory amount or it'll spill over when trying to find the outer bound, I have to test this some time.

  RT-11 V5.3 needs more than 16K by Bill Degnan - 07/23/2016 11:27
Using simH, I found that RT-11 v 5.3 disk I had been using requires more than 16K.

Read More about using simH on a PDP 11.

  Progress / Checking Disks by Bill Degnan - 02/01/2017 11:56
Now that I have a working 11/40 I can start messing with disks.

The first disk I booted was RT-11 v 5.3. It will boot with 16K, but you can't do much with it. I put in the MOS RAM card with 64K so I could attempt newer OS's, maybe even UNIX.

Next I booted XXDP+, which loaded and ran diagnostics. Then I found a 2nd copy on another RL02 disk.

I attempted other RL02 disks on hand, but they were mostly data disks for a 11/44 or VMS.

One disk was labled RSX-11M, it crashed. (or disk bad)

Good. Now I have some scratch disks to use to build alternative operating systems. I have collected a few RL02 disk images.

There's a UNIX 7 on RL02 but I think one needs at least 192K to run it. I will start with a small RT-11 5.0 disk, see how long it takes. I got a copy of UNIX 6 in RL02 format to try after that.

It took about an hour or a little more to build an RT-11 5 distribution disk using PDPGUI and a serial cable. Tested, boots!

Next, UNIX 6.



Buy a Commodore Computer Poster

Popular Topics and FAQs

  • Commodore B Series Tips and Tricks
  • Aerocomp TRS 80 M 1 Expansion Unit DDC
  • Items Wanted
  • Lobo Max 80
  • Zenith Z-19-CN
  • Prototype PET 2001 photo
  • Using Toggle Switches to Analyze Memory
  • Commodore Disk Archive Project
  • PET 2001 Prototype at Gametronics 1977
  • Jim Butterfield Photo
  • IMSAI 8080 With Processor Tech. Cutter
  • Secrecy is the keystone of all tyranny
  • Cromemco System Three
  • Northstar Horizon - Boot Problem
  • Computer History and Restoration Links
  • Commodore BX-256-80 - 8088 Co-processor
  • S-100 board testing with Z-80 ICE
  • Donner 3500 - an early portable computer
  • Digital (DEC) PDP 11/05 NC Assembly
  • Univac 1219 rescue
  • Fido BBS listing node list 6-13-1986
  • PDP 8e
  • MITS 88-2 SIO (2SIO) for BASIC
  • Visual Technology Inc Model 1050
  • Amiga 2500 Restoration
  • The Evolution Of IBM Computers
  • Replacement teletype print hammer head
  • Archiving and Copying Software 101
  • Computers Built 1940 - 1950
  • CBM B-520 (a.k.a B256-80 or B500 256)
  • RCA COSMAC Microkit
  • Commodore 64K C-116 Mods
  • MITS 8800b Turnmon 9600 baud
  • Catweasel, 8in and 5 1/4
  • Raspberry Pi as Gateway to Internet
  • Digital PDP11 late 1969 early 1970
  • PDP 11/40 72 inch cabinet model
  • PDP 11/40 Industrial 11 model
  • Digitial MicroVAX 3100 30 System
  • Digital VAX 4000-200
  • Commodore 64 / 1541 DRIVEKNOCK
  • Booting the System Using RL02 drive
  • PACS: Reflections by Kathleen Mauchly
  • Tele-Graphic Computer Systems Inc.
  • Commodore B Series SID Jukebox?
  • Installing Core into PDP 11/40
  • Setting Up OpenVMS 7.1 DNS CLERK
  • Felt-Tarrant Comptometer Model J
  • NextStation Color
  • Digital Rainbow (PC100-B2)
  • 1970 Compusad Compulogical Tutor
  • Archiving Papertapes Using DSI NC 2400
  • 1976 P.C.C. Features the MAI JOLT 6502
  • 1961 Beckman DEXTIR Computer
  • UNIVAC 1 and UNIVAC File Computer 1
  • Past Issues:

    Rolm 1601 backcvr

    This image was selected at random from the archive. Click image for more photos and files from this set.